Θα πρέπει να αναβαθμίσω τον ιστότοπο μου σε WordPress 5.0;

Το WordPress 5.0, είναι εδώ. Μετά από αρκετές καθυστερήσεις και πάρα πολύ γκρίνια η επόμενη έκδοση του WordPress 5.0 έρχεται με μια μεγάλη αλλαγή.  Το διορθωτή Gutenberg. Ξεχάστε ότι ξέρατε κατά την σύνταξη ενός κειμένου στο WordPress. Τώρα ήρθαν τα blocks.

Μετά τον δημοσιότητα που πήρε η μεγάλη αυτή αλλαγή και λόγου του τρόπου που θα γράφουμε πλέον, αλλά και των πάρα πολλών προβλημάτων που παρουσιάστηκαν, έρχονται κάποια ερωτήματα που θα πρέπει να απαντήσουμε πρίν προβούμε στην αναβάθμιση στο WordPress 5.0.

  • Είναι η κατάλληλη στιγμή για αναβάθμιση;
  • Θα λειτουργεί ο ιστότοπος (site) μου μετά την αναβάθμιση;
  • Την χρειάζομαι;

Είναι τώρα η στιγμή για αναβάθμιση;

Οι γιορτές των χριστουγέννων έρχονται και έχετε προγραμματίσει διακοπές, αν έχετε κάποιο ηλεκτρονικό κατάστημα που τώρα θα αυξηθεί ο φόρτος εργασίας του, ή κάποιο αλλο τύπο ιστότοπου που αυτόν τον καιρό αυξάνει η κίνηση του, τότε αναβάλλετέ το. Αφήστε την αναβάθμιση από τον Ιανουάριο. Τότε ίσως κάποια προβλήματα θα έχουν διορθωθεί, (ήδη έχουν προγραμματιστεί ενημερώσεις).

WordPress Gutenberg

Θα λειτουργεί ο ιστότοπος μου μετά την αναβάθμιση;

Το WordPress 5.0 φέρνει τον νέο διορθωτή Gutenberg. O Gutenberg αλλά τον τρόπο που δουλεύει ο διορθωτής  στο WordPress και πάρα πολλές λειτουργίες που έχουμε βασίζονται πάνω σε αυτόν. Οπότε μια σημαντική αλλαγή όπως αυτή δεν ξέρουμε πως θα επηρεάσει τον ιστότοπο μας και την λειτουργικότητα του.

Δεν είναι όλα τα πρόσθετα έτοιμα, και το σημαντικότερο είναι να γνωρίζουμε αν θα λειτουργούν αφότου πατήσουμε την αναβάθμιση. Η πρόταση μου είναι δημιουργήστε ένα αντίγραφο ασφαλείας, και δοκιμάστε σε αυτό πως θα συμπεριφερθεί το site. Αν δεν υπάρξει πρόβλημα τότε προχωρήστε στην αναβάθμιση και πάλι με επιφυλάξεις.

Επικοινωνήστε με τους δημιουργούς των θεμάτων καθώς και των προσθέτων που χρησιμοποιείτε αν πρόκειτε να προχωρήσουν σε αναβάθμιση με υποστήριξη για τον Gutenberg. Κυρίως μην βιάζεστε μπορούμε να ζήσουμε λίγο ακόμη χωρίς Gutenberg.

Αν πάλι θέλετε να προχωρήσετε στην αναβάθμιση ακόμη και αν δεν υποστηρίζει το θέμα και τα πρόσθετα σας Gutenberg, υπάρχει τότε πρόσθετο Classic Editor. Εγκαταστήστε και ενεργοποιήστε το πρίν την αναβάθμιση σε WP 5.0.

Την χρειάζομαι την αναβάθμιση;

Αν δεν υπάρχει σημαντικός λόγος να προχωρήσετε στην αναβάθμιση στην έκδοση 5, τότε η πρόταση που διαβάζω και συμφωνώ είναι: Περιμένετε
Τον Ιανουάριο του 2019, θα πιο πιθανό είναι να είναι πιο όριμο και σταθερό από σήμερα. Επείδη θέλω και είμαι ειλικρινής το συγκεκριμένο άρθρο είναι γραμμένο σε Gutenberg. Ήθελα να δοκιμάσω και να ζήσω τις συνεχείς αναβαθμίσεις και αλλαγές, αλλά είναι το μόνο site που έχω Gutenberg την στιγμή που γράφω αυτό το άρθρο.

Αν και εσείς είστε βιαστικοί σαν εμένα δημιουργήστε έναν χωριστό ιστότοπο με WordPress και δοκιμάστε και αποφασίστε αν θα προχωρήσετε στην αναβάθμιση στην έκδοση WordPress 5.0

Τέλος για το πότε θα πρέπει να γίνει αναβάθμιση, αυτό εξαρτάται. Κάθε ιστότοπος είναι διαφορετικός και με διαφορετικές παραμέτρους. Πρίν προχωρήσετε επαναλαμβάνω και πάλι κάνουμε αντίγραφο ασφαλείας (backup). Αν τα πρόσθετα και το θέμα είναι συμβατά τότε κάνουμε αναβάθμιση σε WP με Gutenberg, αν όχι πρώτα εγκαθιστούμε το Classic Editor και μετά κάνουμε την αναβάθμιση.

WordPress developer and Meetup - WordCamp Organizer
Άρθρα δημιουργήθηκαν 7

Αφήστε μια απάντηση

Η ηλ. διεύθυνση σας δεν δημοσιεύεται. Τα υποχρεωτικά πεδία σημειώνονται με *

Σχετικά άρθρα

Ξεκινήστε να γράφετε τον όρο αναζήτηση επάνω και πατήστε enter για Αναζήτηση. Πατήστε ESC για ακύρωση.

Επιστροφή επάνω